Sáb. Dic 7th, 2019

MULTIWAN – SEGUNDA PARTE

Todas las referencias al concepto de Multiwan apuntan al proyecto en el que una interfaz LAN puede interactuar con dos o más WAN,  ¡PERO NO CON TODAS A LA VEZ! Es dudoso que por medio de este tipo de configuración se pueda lograr más ancho de banda, podemos por ejemplo, garantizar una conexión estable en la cual si una WAN falla o disminuye su rendimiento logramos compensarlo con las otras, pero, ¿obtener más ancho de banda?, particularmente no lo creo alcanzable.

En nuestro caso, que solo tenemos un proveedor de Internet que nos da 2 Mbit/s; no podemos sacar más de esto… Por ello la configuración de un Multiwan en el caso que nos ocupa, pretende conseguir otros objetivos, además de ser como ya dijimos, una configuración pintoresca y sui generis

Para esta clasificación explicamos dos topologías que tienen una configuración parecida:

La primera:

Esta topología tiene las siguientes características:

  • No hay Swicth o Router
  • Contamos con dos radios de Ubiquiti: Un Nanostation M2 con firmware de Lede configurado en modo Estación para Multiwan y un Nanostation M5 con firmware de Airos configurado en Modo AP.
  • Los radios se enlazan por los puertos Principal y Secundario, alimentándose ambos con un POE de 1 Ampere, con menos de 1 Ampere el rendimiento de la CPU se verá disminuido.
  • La configuración de las VLAN en el radio AP se hará en la interfaz LAN1 que responde al puerto secundario, que a la vez es el puerto de enlace con el radio Cliente.
  • La configuración realizada en el radio Cliente solo utilizará los DHCP de las VLAN, quedando sin uso en esta topología, el DHCP de la interfaz LAN.

La segunda:

Esta topología tiene características diferentes a la anterior entre las que contamos:

  • Tenemos un Switch de Capa 2 no administrable.
  • Cada radio cuenta con su POE de 0.5 Amperes.
  • Se utilizan todos los DHCP configurados en el radio Cliente, de los cuales los que corresponden a las VLAN serán utilizados por el radio AP, y los de LAN serán asignados a los PC y otros dispositivos que se conecten al Swicth
  • El procedimiento de configuración en el radio AP se diferencia en que no se habilita el Acceso Directo a POE y las VLAN se crean en la interfaz LAN0 que responde al puerto Principal

Sobre estos dos ejemplos trata el video que pueden descargar desde AQUI

37 pensamientos sobre “MULTIWAN – SEGUNDA PARTE

  1. Quisiera saber o si pudieran poner en el blog, ya que están muy de moda, un diagrama de irradiacion de un nano m2 y m5, no se si me expreso bien. Osea quisiera ver gráficamente la apertura del angulo de irradiacio’n de estos y si tiran algo también para los lados y hacia atrás.
    Gracias de antemano.

  2. Ulises tengo una duda, en el video observe que tenias varias wan todas a partir de un mismo equipo, asi como diferentes lan asociadas a tus wan segùn tu comodidad,ahora,esto no afecta la velocidad con la que se conecta cada quien,a pesar de que sea un multiportal

  3. Esto no es tan dificil de hacer pero para mejor una implementacion en ves de usar Nano es mejor usar Mikrotik, el propio equipo crea varias WLAN virtuales( multi estacion no vlan) y a la ves te puede hacer un balanceo de carga, pudiendo conectar varias cuentas a la ves a WIFI_ETECSA y aumentando el ancho de banda en la LAN, esto es un poco mas complejo y avanzado, pero funciona y vale la pena si queremos tener un ancho de banda considerable, Saludos

    1. Ya viste el video de la primera parte? Pues allí se explica exactamente cómo funciona un multiwan. No creo que halla rivalidad entre la forma en que se configura Mikrotik y el paquete mwan3 para los equipos que usan Openwrt o Lede -cada uno tiene sus ventajas-. Particularmente me inclino por Mikrotik, realmente su sistema operativo es versátil y potente, pero lo que aquí se explica es lógicamente para los que no tienen antenas Mikrotik. Con el mwan3 también se hace balanceo de carga, se administra ancho de banda, se hacen failover, se bloquean acceso a páginas, se puede acceder a todas las wan desde el host administrador, pero no se puede hacer suma de megas como en Mikrotik, pero eso no es tan eficiente como se dice.

  4. Ulises que tal, tenia una duda antes de cambiar se sistema,con open wrt o lede se puede hacer clonacion de mac; no se si sabras que ahora salio una nueva versión la 18 algo,la has tarequeado, tienes alguna opinión o experiencia de esto

  5. Ulisses tengo una pregunta ya he leido esto mil veces y nada de nada no entiendo porque las vlan no se me activan solo una vez pude activar una en nanostation m2 c que esta como ap pero el lio es que me coje los ip de las vlan que coje el ip de la lan ej: las vlan estan como en tu video 192.168.2….. etc como en tu video exacto y la lan 192.168.1.1….. etc y los moviles que se conectan lo mismo coje el ip de la vlan10 que coje el ip de la lan la vlan20 nunca se activa saludos si pudieras explicar un poco mas esto de conectar la red esta solo con una estacion y un ap saludos si quieres puedes escribirme a mi correo y asi te explico mas y te adjunto fotos de las configuraciones gracias de atemano

    1. Saludos adrianhv:
      Puedes describir como es tu red?.
      Tienes swicth, Router? o solamente dos equipos uno como cliente y el otro como ap?
      Como esperas que funcione el AP? Quieres definir previamente que equipos usaran una vlan y cuales la otra vlan?
      En fin, comparte como esperas que funcione tu red.

      1. Te explico TENGO UN M5 XW CON LEDE en cliente y un m2 xm con software de UMBIQUITI ahora lo que quiero es que cuando los moviles se conecten al m2 salgan por los ip de las vlan asi podria crear mas portales y que cada movil que se conecte salga por una ip distinta…. AHORA UNA PREGUNTA CON SOLO UN AP O SEA UN SOLO NANOM2 EN AP SE ACTIVEN TODAS LAS VLANS EJEMPLO QUE QUIERO
        EL RANGO DE IP DE LA VLAN10 VA DE 2.9 AL 2.14 Y LA VLAN20 DEL 192.168.3.2 AL 192.168.3.10 QUE CUANDO SE CONECTEN AL AP SE AGOTEN LOS IP DE LA VLAN10 LOS RESTANTES QUE SE CONECTEN SALGAN POR LA VLAN20 DIME SI ESO FUNCIONA ASI O DE OTRA MANERA SALUDOS

        1. Saludos adrianhv:
          Antes de proseguir explicame como tienes puenteado los dos equipos.
          Pero te puedo adelantar lo siguiente: Puedes crear todas las vlan que desees en el AP pero estas deben ser tagueadas con las que se crean en el multiwan, de lo contrario no podran ser encaminadas al Internet. Existe una forma en Ubiquiti de hacer multiple AP con un solo equipo y eso facilitaria un poco el direccionamiento.
          Recordemos que no estamos tratando de igualar lo que se hace con Mikrotik

  6. ULISES GRACIAS POR LA PRONTA RESPUESTA ya he logrado que me salgan las vlans en todo o sea ya esta configurada la red ahora el PROBLEMA ES QUE PONGO UNA CUENTA EN CUALQUIRA DE LAS VLAN Y TODOS SIGUEN COGIENDO CONEXION EJemplo—- SI UN MOVIL QUE ESTA SALIENDO POR LA VLAN10 SE LOGUEA EL QUE ESTE EN LA VLAN20 TAMBIEN COGE INTERNET PERO VARIA HAVECES TIENE Y A VECES LE DA LA PAGINA DE INICIO DE SECION NO ENTIENDO ESTO A Y OTRA COSA LOS MOVILES POR LA ETK NI POR UTIL ETECSA NI POR NADA PUEDEN PONER LA CUENTA A VECES POR EL NAVEGADOR UN MOMENTO SI TIRA LA PAGINA PONES LA CUENTA Y LISTO EL PROBLEMA ES A LA HORA DE QUITARLA AUNQUE DES CERRAR SESION SE QUEDA LA CUENTA ENGANCHADA SI ME PUDIERAS FACILITAR UN CORREO PRIVADO TE ENVIARIA SCREENSHOOT DE LO QUE ME PIDAS Y YA SABRAS MEJOR saludos

  7. A Y OTRA COSA A MODO DE INFORMACION ESTO DEL LOGUEO CON ETECSA Y LA CONECCION DE CUENTAS Y LA DESCONECCION DE CUENTAS SOLO PASA CUANDO ESTAN LAS 3 WAN ACTIVAS EJEMPLO—–CUANDO TENGO UN MOVIL CONECTADO A LA VLAN20 QUE ESTA SALE POR LA WAN3 YO DESACTIVO LA WAN Y LA WAN2 O SEA EN INTERFACES LE DOY STOP TODO SALE PERFECTO PUEDO PONER LA CUENTA Y DESCONECTARLA POR LA ETK O POR LO QUE QUIRA Y NO SE QUEDA LA CUENTA EGANCHADA NI NADA SABES A QUE SE DEBE ESTO GRACIAS DE ANTEMANO Y DISCULPA POR MOLESTAR TANTO JAJAJAJAJJAJAJAJAJAJA

  8. Saludos Nelson:
    Tranquilo que todo puede resolverse, primero no hagas mas nada con el router, es decir no vuelvas flashearlo. Consigue la aplicacion WINSCP, cuando la tengas confirma por aqui. Te ire dando los pasos que siguien.

    Esta es la imagen con que flashaste el router?: https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/openwrt-ar71xx-generic-tl-wr1043nd-v3-squashfs-factory.bin

    Descargate tambien esta: https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr1043nd-v2-squashfs-sysupgrade.bin

    Y el winscp desde: http://www.mediafire.com/file/qp0yu0on73lts1e/WinSCP-5.13.5-Setup.exe/file

    Has usado alguna vez el winscp?

    Sabes si el firmware original del router era esta version “FW 3.16.9 build 150514” antes de flashear a openwrt?

    1. Gracias por responderme hermano no sabes lo agradecido que voy a estar contigo.
      Si fue esa imagen la que puse,ya descargué la imagen que me digiste y el intalador del winscp (no se trabajar con ese programa 1ra ves que lo veo).pero bueno cachareando se aprende.
      El firmware no se si era ese, pero el original debe ser porque el que me lo vendio me lo dio con la caja que se lo habian traido hace poco.
      Te llegó el correo que te envié?
      Bueno espero aqui tus respuestas y gracias de ante mano.

      1. Saludos Nelson:
        El winscp servirá para copiar en el router la versión del firmware 15.05.1 y actualizar desde alli. El winscp se trabaja como en el totalcomander es decir con dos paneles o dos exploradores uno a cada lado de la pantalla, generalmente del lado derecho estará el router y del lado izquierdo tu pc. Ya verás que es fácil. Una vez instalado el winscp lo ejecutas y en el botón desplegable del titulo “File Protocol” selecciona SCP, en “Host Name” pones la IP del router y completa “user name” y si no has puesto “password” lo dejas en blanco, el “port number” lo dejas como está. Luego click abajo en el botón “Login”. Te abrirá otra ventana a la que responderás “Yes”, luego quedará tu escritorio con dos paneles. Familiarízate con ello antes de seguir.
        El firmware que descargaste cámbiale el nombre por uno mas corto, puede ser “firmware”, ubícalo en el panel de la izquierda, recuerda que esto es como un explorador busca la ruta hasta donde está el archivo.
        Ahora en el panel de la derecha ubícate en el directorio “tmp”, haciendo clic en el botón desplegable que está seleccionado con “root” da clic donde aparece ” / root ” y te saldrán listados todos los directorios del ruter, dale doble clic al directorio tmp para que se abra.
        En el panel izquiero selecciona el firmware y arrastra y suelta en el panel derecho para copiarlo dentro del directorio tmp.
        Comprueba que el panel activo sea el de la derecha, lo sabrás porque se resalta la barra azul.
        Ahora busca arriba y a la izquierda de la ventana un icono negro que tiene dentro este simbolo > se trata de una terminal de linux, al darle clic al icono se abrirá una ventana con fondo negro, donde dice “Enter command” escribe lo siguiente:
        sysupgrade -n -F firmware.bin
        (suponiendo que el nombre que le pusiste al firmware sea “firmware”). Y dale al botón “Execute”.
        Espera a que haga su proceso, cuando haya terminado ingresa con tu navegador la ip del router y quizas tengas la sorpresa que ya tienes la interfaz de Luci, después de esto si quieres puedes actualizar a la versión mas reciente y estable que es la 18.06.1.

        1. Muchas gracias pero de veras muchas gracias hermano resolvi con lo que me digiste gracias de veras, espero tengas mucha salud y mucha suerte ya logré entrar al router.
          Muy buena la pagina espero sigas asi con tanta sabiduria.
          Saludos para TI:ulisescesar

    1. Saludos nelson:
      Me satisface que hayas recuperado tu router. Gracias por tus palabras.
      Para actualizar vas a System > Backup / flash firmware > y luego te desplazas hasta “Flash new firmware image”, cargas el archivo donde dice “Examinar” y luego “Flash Image”. Debes haber descargado dos archivos uno …factory.bin y el otro ….sysupgrade.bin. Primero cargas el factory y después vuelves y cargas el sysupgrade.

      1. Hola y saludos….
        Instale un lhg5 Openwrt en Estacion..lo tengo conectado el lan1 de un NanoStation M2 que esta como AP…la pregunta es que configurado mwan3 y las vlan cuando me conecto por el M2 el portal “Binvenido” no me carga; automáticamente sale en pantalla intentando hacerlo y “conexion refused”
        hay algun camino que este tomando…firewall…no se!
        que crees de esto…………..
        SALUDOS

        1. regis1990:
          Al final del artículo hay un link de descarga del video donde se explica como hacerlo con ambas topologías, trata de descargarlo y compara con lo que tienes hecho, si te es muy difícil vuelve a hacer todo el proceso. Saludos

  9. Saludos ulisescesar:
    Estoy pensando hacer el multiwan con lede en un loco m2 y quiero que las tres vlans que cree me salgan por la wifi de un router, tengo un linksys wrt54g corriendo DD-WRT, he estado pensando en 3 redes con diferentes ssid, o tal vez una sola, la duda que tengo es como sacar las vlans por la wifi, ya que bajan al router por un único puerto físico, he leído algo de un enlace troncal para permitir la comunicación entres las vlans, pero tengo duda sobre eso, si me puedieras orientar te lo agradecería.

  10. Todavía no puedo resolver el problema de que no se puede poner las cuentas con la ETK no se que es lo que pasa todo está hecho como los 2 videos saludos si pudieras darle solución a este preblema sería una gran ayuda saludos y que te mejores

  11. Hola y saludos por el nuevo año muchas felicidades a todos quisiera saber si ya alguien le dio solucion a lo del problema que no importa en que vlan estes conectado que vas a tener internet en todas junta creo que es algo en el firewall por cierto he visto los videos un millon de veces y todo esta exacto a los 2 videos mi tipologia de red es del tipo que se explica en el segundo video el 1er ejemplo slds

Deja un comentario